24 junio, 2024

Si bien, tenemos un entorno web, que nos facilita la configuración del dispositivo, algunos aspectos del mismo, los vamos a configurar a través de putty, primero que es más educativo, y segundo que hay algunas otras plataformas que por un tema de espacio y/o rendimiento, no soportan Luci, (el entorno web).

El primer acceso, en aquellos dispositivos que no tienen Luci, se debe hacer por telnet, ya que ssh está desactivado por defecto. Una vez configurado el password de root, ya podemos acceder vía SSH.
El plan de configuración será la creación de:

  •  2 Vlan.
  •  Interface LAN, con tres puertos de clientes DHCP64.
  •  Interface WAN, para la conexión al router del ISP.
  •  Interface Wan6in4, tunnel 6in4 con HE.net, que nos provee de IPv6.
  •  Interface Wifi, como punto de acceso doble stack 6/4.

Accedemos, con Putty a 192.168.1.1, y nos movemos al directorio /etc/config, el directorio que contiene las configuraciones del dispositivo.Vamos a editar el fichero que contiene las configuraciones de red /etc/config/networkconfig

config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'
config globals 'globals'
option ula_prefix 'fxxx:xxxx:xxxx::/48'
config interface 'lan'
option ifname 'eth0.1'
option force_link '1'
option type 'bridge'
option proto 'static'
option ipaddr '192.168.1.1'
option netmask '255.255.255.0'
option ip6assign '60'
config switch
option name 'eth0'
option reset '1'
option enable_vlan '1'
config switch_vlan
option device 'eth0'
option vlan '1'
option ports '0 1 2 3 4 5t'

 Dejamos la parte de:

config interface 'loopback' 
option ifname 'lo' 
option proto 'static'
option ipaddr '127.0.0.1' 
option netmask '255.0.0.0' 
config globals 'globals' 
option ula_prefix 'fxxx:xxxx:xxxx::/48'

Como ya tengo un router en 192.168.1.0/24 y necesitamos acceder al router para gestionarlo, vamos a configurar el dispositivo como 192.168.2.100/24, sobre la Vlan2.

config interface 'lan'
option ifname 'eth0.2'
option force_link '1'
option type 'bridge'
option proto 'static'
option netmask '255.255.255.0'
option ip6assign '60'
option macaddr '00:11:22:33:44:55'
option ipaddr '192.168.2.100' #Nueva IP de Gestión y acceso al router.

 Vamos a crear un puerto de enlace con el router del ISP, que será cliente dhcp, al que llamaremos WAN, y lo situamos en la Vlan1.

config interface 'wan'
option ifname 'eth0.1'
option proto 'dhcp'
option macaddr '00:11:22:33:44:56'
option type 'bridge'

Activamos el soporte Vlan en el switch y las configuramos:

config switch
option name 'eth0'
option reset '1'
option enable_vlan '1' 
# Asignamos a la Vlan1 a puerto de switch 1 y a la CPU. 
config switch_vlan
option device 'eth0'
option vlan '1'
option ports '0 5t'
 # Asignamos a la Vlan2 al resto. 
config switch_vlan
option device 'eth0'
option vlan '2'
option ports '1 2 3 4 5t'

Como en España, los ISP clásicos, no parece que proporcionen IPV6, y me interesaba mucho el tema, en la web HE.net, hace unos años, solicité para pruebas varios pools de IPv6, (tengo bajo mi cuentas varias asignaciones /64 segmentadas en /48) a las que se puede acceder mediante un túnel 6in4. Actualmente, lo tengo funcionando a la perfección a través de un D-Link 600, el cual provee de doble stack 6/4 a mis dispositivos de red, y dado que tengo en mi cuenta varias, voy a coger una de ellas para implementarla en este proyecto.

config interface 'Wan6in4'
option proto '6in4'
option peeraddr '216.66.xx.xx'
option ip6addr '2001:xxx:25:xx::2/64'
option ip6prefix '2001:xxx:26:xx::/64'
option tunnelid 'xxxxxx'
option username 'xxxxx'
option updatekey 'xxxxxxxxxxxxxxxxxxxxxx'

Donde:

  • Option peeraddr: Server IPv4 Address
  • Option ip6addr: Client IPv6 Address
  • Option ip6prefix: Routed /64
  • Option tunnelid: Tunnel ID
  • Option username: Username de la cuenta.
  • Option updatekey:

En la pestaña Advance de tu cuenta en tunnelbroker.net Ya hemos configurado el tunel, ahora creamos la interface Wifi y no asignamos ninguna ruta estática.

config route
config interface 'Wifi'
option proto 'none'

Vamos a configurar la parte del enlace WIFI, el fichero de configuración del mismo está localizado en /etc/config/wireless

config wifi-device 'radio0'
option type 'mac80211'
option hwmode '11g'
option path 'pci0000:00/0000:00:01.0'
option htmode 'HT20'
option txpower '30'
option channel 'auto'
option country 'ES'

config wifi-iface
option device 'radio0'
option mode 'ap'
option ssid 'IPV6_NET'
option encryption 'psk-mixed+tkip+ccmp'
option key 'xxxxxxxxxx'
option network 'lan wan Wifi'

Ya tenemos completa la parte de lan y wireless, completada, pero no funcional, nos faltaría re-arrancar la parte de red, dejar nuestro PC en modo DHCP, y acceso al router a través de la ip 192.168.2.100, pero aún así, tendríamos fuciones que no estarían operativas, como por ejemplo el túnel 6in4.

Por ello, hay que tener paciencia y pasar a la siguiente entrada, que es la que configura el firewall.

Deja una respuesta

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *

Este sitio usa Akismet para reducir el spam. Aprende cómo se procesan los datos de tus comentarios.

Uso de cookies

Este sitio web utiliza cookies para que usted tenga la mejor experiencia de usuario. Si continúa navegando está dando su consentimiento para la aceptación de las mencionadas cookies y la aceptación de nuestra política de cookies, pinche el enlace para mayor información.plugin cookies

ACEPTAR
Aviso de cookies